This is just a quick note, when installing SharePoint 2010 on SQL Server 2008 (not R2), besides all the pre-requisites, do not forget that you will need the Cumulative Update package 2 for SQL Server 2008 Service Pack 1. You can get that from here.

Without CU2 you will the the message:

SQL Server at SQLBox\InstanceName has an unsupported version 10.0.2531.0. Please refer to “” for information on the minimum required SQL Server versions and how to download them.